Inicio / Alerta Temprana / Avisos Seguridad / Vulnerabilidad de escalada de privilegios en cliente NordVPN

Vulnerabilidad de escalada de privilegios en cliente NordVPN

Fecha de publicación: 
10/09/2018
Importancia: 
4 - Alta
Recursos afectados: 
  • Cliente de VPN NordVPN 6.14.28.0
Descripción: 

Existe una vulnerabilidad de ejecución de código explotable en la funcionalidad de conexión del cliente VPN NordVPN 6.14.28.0. Un archivo de configuración OpenVPN especialmente diseñado podría causar una escalada de privilegios, lo que podría permitir la ejecución de comandos arbitrarios con los privilegios del sistema.

Solución: 

Un parche ha sido incluido en la actualización del cliente VPN el 8 de agosto. Se recomienda actualizar los clientes VPN a la versión actual.

Detalle: 

El investigador Paul Rascagneres de Cisco Talos, ha descubierto que si se modifica el archivo de configuración de OpenVPN y se agrega el parámetro up y a continuación la ruta de ejecución de un programa cualquiera, el programa se ejecutará con privilegios de sistema. Se ha reservado el identificador CVE-2018-3952 para esta vulnerabilidad.

Encuesta valoración